ddply () under Rcharts section

Data Society – Home Forums Interactive visualizations ddply () under Rcharts section

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Merav Yuravlivker 11 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18329

    Hoang Tran Trung
    Participant

    My Achievements

    Concept review passed! IconExercise set done! IconExercise set done! IconSection completed! IconConcept review passed! IconSection completed! IconPost published! IconFeedback given! IconExercise done! IconConcept review passed! IconQuiz completed IconCourse completed! IconSetup completed! Icon

    In the homework answer for Hispanic population under section “Dynamics Graph with Rcharts”
    byState <- ddply(hispanic.pop, .(State), numcolwise(sum))
    give me an error
    Error in match.fun(FUN) : '40' is not a function, character or symbol
    Can you tell me what’s wrong with the ddply()?

    #18333

    Merav Yuravlivker
    Keymaster

    My Achievements

    Concept review passed! IconExercise set done! IconConcept review passed! IconExercise set done! IconConcept review passed! IconExercise set done! IconExercise set done! IconConcept review passed! IconConcept review passed! IconSection completed! IconConcept review passed! IconSection completed! IconConcept review passed! IconConcept review passed! IconExercise set done! IconExercise set done! IconSection completed! IconConcept review passed! IconSection completed! IconAnswered a post IconFeedback given! IconExercise done! IconConcept review passed! IconQuiz completed IconCourse completed! IconSetup completed! Icon

    Hi Hoang,

    Thank you for your post! I tried recreating the error, but the code ran on my computer. There may be a few reasons that you’re seeing this error – double check the structure of your data with the str() function, and also make sure that you installed all the packages you need to run ddply().

    One of the best troubleshooting tips I have is to just restart R and RStudio, and try again. Let me know if that helps!

    Best,
    Merav

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.